RENMX

Official website of the Renegades online community

Important security update

Posted by on Apr 17, 2015 in Minecraft

Some of you may have read yesterday that a huge bug present in Minecraft for the past two years was made public and an easy to use tool to use the exploit was published. The bug allowed an attacker to send a crafted inventory update packet to the server which contained a lot of nested data, so much data that it would overwhelm the server (eating up all available CPU Cycles and Memory) until it caused a crash.

This is a very serious bug and so at the first opportunity I have updated all our four servers to be immune from this problem. If you run or administrate a Minecraft server I would urge you to upgrade to the latest version of Spigot immediately or wait for Mojang to release 1.8.4 of the server software which they may have done by the time this post goes live.