RENMX

Official website of the Renegades online community

Update to when we’ll be accepting 1.8 clients

Posted by on Sep 21, 2014 in Minecraft

Many of you have noticed that other servers you play on are now accepting 1.8 clients. These servers do not offer any 1.8 functionality like the new blocks they merely allow 1.8 clients to connect to their 1.7.10 server.

This is performed by using a protocol compatibility patch. We’ve used such patches previously to accept 1.6 clients when we were on 1.5.x and to accept 1.7 clients when we were on 1.6.x

Unfortunately we cannot yet offer the same compatibility with 1.8 clients as the patch isn’t very good and there are lots of bugs in 1.8 that still need to be fixed. Today I tried the latest version of the patch with our plugins and found various compatibility issues. Disguises do not function and crash the server which would mean your disguise cards would be useless, the online player list that is viewed by holding the tab key only shows white names, no colours and our holograms like those found in our spawn sewer simply don’t work.

However these aren’t the biggest issues I discovered, 1.8 has incredibly poor performance for some reason. I don’t feel it is worth supporting until Mojasoft have fixed the performance issues.

So it’ll be a lot longer before we accept 1.8 clients I’m afraid, but you can still use 1.7.2 to 1.7.10 to connect to our server in the meantime. As always I’m keeping up to date with the latest developments and I will update us to the newest version of the game as soon as I can.